[phpBB Debug] PHP Notice: in file /viewtopic.php on line 981: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead
[phpBB Debug] PHP Notice: in file /viewtopic.php on line 981: getdate(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead
Tynsoe Projects • View topic - GeekTool 3 RC5 startup issue

GeekTool 3 RC5 startup issue

GeekTool 3 RC5 startup issue

Postby squidsoup » Mon Mar 01, 2010 9:19 pm

Hi there,

I have an issue where GeekTool does not run on startup. GeekTool is configured as a startup item, and the run on startup checkbox is ticked. Every time I reboot however I need to manually enable GeekTool by visiting System | Geektool and clicking show. Any thoughts on this issue would be appreciated. Other than that it works perfectly! :)
squidsoup
 
Posts: 6
Joined: Mon Mar 01, 2010 9:44 am

Re: GeekTool 3 RC5 startup issue

Postby danilushka » Mon Mar 01, 2010 9:33 pm

I have the same problem on a Macbook Pro running 10.6.2. Irritating nuisance.
danilushka
 
Posts: 5
Joined: Mon Mar 01, 2010 9:30 pm

Re: GeekTool 3 RC5 startup issue

Postby squidsoup » Wed Mar 03, 2010 8:52 am

Good to hear that it's not just me - hopefully someone has a resolution out there.
squidsoup
 
Posts: 6
Joined: Mon Mar 01, 2010 9:44 am

Re: GeekTool 3 RC5 startup issue

Postby ybizeul » Fri Mar 05, 2010 6:55 pm

Quoting Mike here :
I (like some others) have seen issues with geektool appearing to not start until the pref pane is opened sometime after boot. I finally found the solution. Make sure quartz extreme 2d is enabled. After I checked mine, found it was disabled. Enabled, all good.

http://wiki.awkwardtv.org/wiki/Enable_Q ... 2D_Extreme


Please post your resulsts here
ybizeul
Site Admin
 
Posts: 133
Joined: Fri Jan 22, 2010 4:34 pm

Re: GeekTool 3 RC5 startup issue

Postby Joresch » Mon Mar 08, 2010 5:15 pm

Sorry but these terminal commands does not work for me... I also have troubles with Geektool not appearing at the startup.
Joresch
 
Posts: 1
Joined: Mon Mar 08, 2010 5:12 pm

Re: GeekTool 3 RC5 startup issue

Postby danilushka » Wed Mar 17, 2010 1:48 am

I enabled both Quartz2D and QuartzExtreme on my Macbook Pro, verified via the command line that they are indeed enabled, and it did not solve the problem. My MacPro 8-core boots and displays the geeklets just fine--my macbook pro does not. They are both running 10.6.2 Snow Leopard. Somewhere in Geektool, there is a hardware dependency--it would be interesting to find out which hardware configurations have the problem and which do not.
danilushka
 
Posts: 5
Joined: Mon Mar 01, 2010 9:30 pm

Re: GeekTool 3 RC5 startup issue

Postby squidsoup » Wed Mar 17, 2010 5:41 am

If it is hardware related, here are my specs:

  • Model Name: iMac
  • Model Identifier: iMac10,1
  • Processor Name: Intel Core 2 Duo
  • Processor Speed: 3.06 GHz
  • Chipset Model: ATI Radeon HD 4670

Snow Leopard (10.6.2)
squidsoup
 
Posts: 6
Joined: Mon Mar 01, 2010 9:44 am

Re: GeekTool 3 RC5 startup issue

Postby danilushka » Thu Mar 18, 2010 3:31 am

I wonder if it is unique to Core 2 Duo systems--premature speculation of course...but...

Both of my systems are running Snow Leopard 10.6.2.
This system, MacPro, displays geeklets properly on boot right "out of the box"--no configuration of Quartz functions required:
Model Name: Mac Pro
Model Identifier: MacPro2,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 3 GHz
Number Of Processors: 2
Total Number Of Cores: 8
L2 Cache (per processor): 8 MB
Memory: 13 GB
Bus Speed: 1.33 GHz
Boot ROM Version: MP21.007F.B08
SMC Version (system): 1.15f3

This system, Macbook Pro, does not, even with the enabling of Quartz functions:
Model Name: MacBook Pro
Model Identifier: MacBookPro2,2
Processor Name: Intel Core 2 Duo
Processor Speed: 2.33 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 3 GB
Bus Speed: 667 MHz
Boot ROM Version: MBP22.00A5.B07
SMC Version (system): 1.12f5
danilushka
 
Posts: 5
Joined: Mon Mar 01, 2010 9:30 pm

Re: GeekTool 3 RC5 startup issue

Postby ybizeul » Mon Mar 22, 2010 6:25 pm

This is a really weird issue I did not heard about before.

I just wanted to add that, anyways if GeekTool is indeed enabled in startup items (to check that, quit System Preferences, open it again, go into Accounts preferences and in Startup, check that GeekTool is there), then an error message should be displayed in Console when your session starts. SOmething that says that GeekTool crashed, and eventually pointing to a crash report.
ybizeul
Site Admin
 
Posts: 133
Joined: Fri Jan 22, 2010 4:34 pm

Re: GeekTool 3 RC5 startup issue

Postby squidsoup » Mon Mar 22, 2010 7:31 pm

Found this in /var/system.log:

Code: Select all
Mar 23 07:29:54 Peachy [0x0-0x16016].org.tynsoe.geektool3[213]: 2010-03-23 07:29:54.071 osascript[420:903] Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types:  dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found.  Did find:
Mar 23 07:29:54 Peachy [0x0-0x16016].org.tynsoe.geektool3[213]:    /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper
Mar 23 07:29:54 Peachy [0x0-0x16016].org.tynsoe.geektool3[213]: osascript: OpenScripting.framework - scripting addition "/Library/ScriptingAdditions/Adobe Unit Types.osax" declares no loadable handlers.
squidsoup
 
Posts: 6
Joined: Mon Mar 01, 2010 9:44 am

Next

Return to GeekTool

Who is online

Users browsing this forum: No registered users and 4 guests

cron